$re = '/monitoringLayer_amfsData\.(amfs_cartProtectedSpace|amfs_cartWorkspace)_[0-9]_(monitoredKinematics|monitoredStructure|originX|originY|originZ|originA|originB|originC|length|width|height)/';
$str = 'monitoringLayer_amfsData.amfs_cartProtectedSpace_9_height';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);