package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`monitoringLayer_amfsData\.(amfs_cartProtectedSpace|amfs_cartWorkspace)_[0-9]_(monitoredKinematics|monitoredStructure|originX|originY|originZ|originA|originB|originC|length|width|height)`)
var str = `monitoringLayer_amfsData.amfs_cartProtectedSpace_9_height`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}