import Foundation
let pattern = #"\/(freebies|graphics|websites|ui-kits|premium)\/|pg-(.*[0-9])|s-(.*)\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://localhost:8888/freebies/pg-2/
http://localhost:8888/graphics/pg-2031/
http://localhost:8888/fake/pg-2/s-abcddsagla213414/
http://localhost:8888/fake/pg-2/s-test/
http://localhost:8888/graphics/
http://localhost:8888/premium-pass/
http://localhost:8888/freebies/test/pg-2
http://localhost:8888/freebies/s-test/dladla
http://localhost:8888/freebies/s-a/pg-2
http://localhost:8888/items/test-freebies-item-name/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)