#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(freebies|graphics|websites|ui-kits|premium)\/|pg-(.*[0-9])|s-(.*)\/"
Local $sString = "http://localhost:8888/freebies/pg-2/" & @CRLF & _
"http://localhost:8888/graphics/pg-2031/" & @CRLF & _
"http://localhost:8888/fake/pg-2/s-abcddsagla213414/" & @CRLF & _
"http://localhost:8888/fake/pg-2/s-test/" & @CRLF & _
"http://localhost:8888/graphics/" & @CRLF & _
"http://localhost:8888/premium-pass/" & @CRLF & _
"http://localhost:8888/freebies/test/pg-2" & @CRLF & _
"http://localhost:8888/freebies/s-test/dladla" & @CRLF & _
"http://localhost:8888/freebies/s-a/pg-2" & @CRLF & _
"http://localhost:8888/items/test-freebies-item-name/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")