use strict;
my $str = 'http://localhost:8888/freebies/pg-2/
http://localhost:8888/graphics/pg-2031/
http://localhost:8888/fake/pg-2/s-abcddsagla213414/
http://localhost:8888/fake/pg-2/s-test/
http://localhost:8888/graphics/
http://localhost:8888/premium-pass/
http://localhost:8888/freebies/test/pg-2
http://localhost:8888/freebies/s-test/dladla
http://localhost:8888/freebies/s-a/pg-2
http://localhost:8888/items/test-freebies-item-name/';
my $regex = qr/\/(freebies|graphics|websites|ui-kits|premium)\/|pg-(.*[0-9])|s-(.*)\//mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}