# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/(freebies|graphics|websites|ui-kits|premium)\/|pg-(.*[0-9])|s-(.*)\/"
test_str = ("http://localhost:8888/freebies/pg-2/\n"
"http://localhost:8888/graphics/pg-2031/\n"
"http://localhost:8888/fake/pg-2/s-abcddsagla213414/\n"
"http://localhost:8888/fake/pg-2/s-test/\n"
"http://localhost:8888/graphics/\n"
"http://localhost:8888/premium-pass/\n"
"http://localhost:8888/freebies/test/pg-2\n"
"http://localhost:8888/freebies/s-test/dladla\n"
"http://localhost:8888/freebies/s-a/pg-2\n"
"http://localhost:8888/items/test-freebies-item-name/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.