// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(freebies|graphics|websites|ui-kits|premium)\/|pg-(.*[0-9])|s-(.*)\/").unwrap();
let string = "http://localhost:8888/freebies/pg-2/
http://localhost:8888/graphics/pg-2031/
http://localhost:8888/fake/pg-2/s-abcddsagla213414/
http://localhost:8888/fake/pg-2/s-test/
http://localhost:8888/graphics/
http://localhost:8888/premium-pass/
http://localhost:8888/freebies/test/pg-2
http://localhost:8888/freebies/s-test/dladla
http://localhost:8888/freebies/s-a/pg-2
http://localhost:8888/items/test-freebies-item-name/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}