import Foundation
let pattern = #"(?!^\-)\D"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"-98+-098.ojhfiour0989e87"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)