# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^\-)\D//g;t' <<< "-98+-098.ojhfiour0989e87"