use strict;
my $str = '-98+-098.ojhfiour0989e87';
my $regex = qr/(?!^\-)\D/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";