$re = '/(?!^\-)\D/';
$str = '-98+-098.ojhfiour0989e87';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;