const regex = /(?!^\-)\D/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^\\-)\\D', 'g')
const str = `-98+-098.ojhfiour0989e87`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);