import Foundation
let pattern = #"SetVariable>[\w\n\t\s=\":<>\/\-_.]*?stringValue=\"([\w\n\t\s=\":<>\/\-_.]*?)\"\/>[\w\n\t\s=\":<>\/\-_.]*?(?!booleanValue)[\w\n\t\s=\":<>\/\-_.]*?VariableToSet stringValue=\"serviceName\"[\w\n\t\s=\":<>\/\-_.]*?L7p:SetVariable>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<L7p:VariableToSet stringValue="dateTo"/>
</L7p:SetVariable>
<L7p:SetVariable>
<L7p:Base64Expression stringValue="UmljZXJjYURvY3VtZW50aURpc3BvbmliaWxpSFhFcG9zdFNQ"/>
<L7p:Enabled booleanValue="false"/>
<L7p:VariableToSet stringValue="serviceName"/>
</L7p:SetVariable>
<L7p:Include>
<L7p:Enabl
<L7p:Base64Expression stringValue="Q1RUUklCVVQ="/>
<L7p:VariableToSet stringValue="SpCodeTablesSP.inputdata.TableCodeId"/>
</L7p:SetVariable>
<L7p:SetVariable>
<L7p:Base64Expression stringValue="U3BDb2RlVGFibGVzU1A="/>
<L7p:VariableToSet stringValue="serviceName"/>
</L7p:SetVariable>
<L7p:Include>
<L7p:Pol
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)