#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)SetVariable>[\w\n\t\s=\":<>\/\-_.]*?stringValue=\"([\w\n\t\s=\":<>\/\-_.]*?)\"\/>[\w\n\t\s=\":<>\/\-_.]*?(?!booleanValue)[\w\n\t\s=\":<>\/\-_.]*?VariableToSet stringValue=\"serviceName\"[\w\n\t\s=\":<>\/\-_.]*?L7p:SetVariable>"
Local $sString = " <L7p:VariableToSet stringValue="dateTo"/>" & @CRLF & _
" </L7p:SetVariable>" & @CRLF & _
" <L7p:SetVariable>" & @CRLF & _
" <L7p:Base64Expression stringValue="UmljZXJjYURvY3VtZW50aURpc3BvbmliaWxpSFhFcG9zdFNQ"/>" & @CRLF & _
" <L7p:Enabled booleanValue="false"/>" & @CRLF & _
" <L7p:VariableToSet stringValue="serviceName"/>" & @CRLF & _
" </L7p:SetVariable>" & @CRLF & _
" <L7p:Include>" & @CRLF & _
" <L7p:Enabl" & @CRLF & _
"" & @CRLF & _
" <L7p:Base64Expression stringValue="Q1RUUklCVVQ="/>" & @CRLF & _
" <L7p:VariableToSet stringValue="SpCodeTablesSP.inputdata.TableCodeId"/>" & @CRLF & _
" </L7p:SetVariable>" & @CRLF & _
" <L7p:SetVariable>" & @CRLF & _
" <L7p:Base64Expression stringValue="U3BDb2RlVGFibGVzU1A="/>" & @CRLF & _
" <L7p:VariableToSet stringValue="serviceName"/>" & @CRLF & _
" </L7p:SetVariable>" & @CRLF & _
" <L7p:Include>" & @CRLF & _
" <L7p:Pol"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")