$re = '/SetVariable>[\w\n\t\s=\":<>\/\-_.]*?stringValue=\"([\w\n\t\s=\":<>\/\-_.]*?)\"\/>[\w\n\t\s=\":<>\/\-_.]*?(?!booleanValue)[\w\n\t\s=\":<>\/\-_.]*?VariableToSet stringValue=\"serviceName\"[\w\n\t\s=\":<>\/\-_.]*?L7p:SetVariable>/m';
$str = ' <L7p:VariableToSet stringValue="dateTo"/>
</L7p:SetVariable>
<L7p:SetVariable>
<L7p:Base64Expression stringValue="UmljZXJjYURvY3VtZW50aURpc3BvbmliaWxpSFhFcG9zdFNQ"/>
<L7p:Enabled booleanValue="false"/>
<L7p:VariableToSet stringValue="serviceName"/>
</L7p:SetVariable>
<L7p:Include>
<L7p:Enabl
<L7p:Base64Expression stringValue="Q1RUUklCVVQ="/>
<L7p:VariableToSet stringValue="SpCodeTablesSP.inputdata.TableCodeId"/>
</L7p:SetVariable>
<L7p:SetVariable>
<L7p:Base64Expression stringValue="U3BDb2RlVGFibGVzU1A="/>
<L7p:VariableToSet stringValue="serviceName"/>
</L7p:SetVariable>
<L7p:Include>
<L7p:Pol';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);