# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"SetVariable>[\w\n\t\s=\":<>\/\-_.]*?stringValue=\"([\w\n\t\s=\":<>\/\-_.]*?)\"\/>[\w\n\t\s=\":<>\/\-_.]*?(?!booleanValue)[\w\n\t\s=\":<>\/\-_.]*?VariableToSet stringValue=\"serviceName\"[\w\n\t\s=\":<>\/\-_.]*?L7p:SetVariable>"
test_str = (" <L7p:VariableToSet stringValue=\"dateTo\"/>\n"
" </L7p:SetVariable>\n"
" <L7p:SetVariable>\n"
" <L7p:Base64Expression stringValue=\"UmljZXJjYURvY3VtZW50aURpc3BvbmliaWxpSFhFcG9zdFNQ\"/>\n"
" <L7p:Enabled booleanValue=\"false\"/>\n"
" <L7p:VariableToSet stringValue=\"serviceName\"/>\n"
" </L7p:SetVariable>\n"
" <L7p:Include>\n"
" <L7p:Enabl\n\n"
" <L7p:Base64Expression stringValue=\"Q1RUUklCVVQ=\"/>\n"
" <L7p:VariableToSet stringValue=\"SpCodeTablesSP.inputdata.TableCodeId\"/>\n"
" </L7p:SetVariable>\n"
" <L7p:SetVariable>\n"
" <L7p:Base64Expression stringValue=\"U3BDb2RlVGFibGVzU1A=\"/>\n"
" <L7p:VariableToSet stringValue=\"serviceName\"/>\n"
" </L7p:SetVariable>\n"
" <L7p:Include>\n"
" <L7p:Pol")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.