use strict;
my $str = ' <L7p:VariableToSet stringValue="dateTo"/>
</L7p:SetVariable>
<L7p:SetVariable>
<L7p:Base64Expression stringValue="UmljZXJjYURvY3VtZW50aURpc3BvbmliaWxpSFhFcG9zdFNQ"/>
<L7p:Enabled booleanValue="false"/>
<L7p:VariableToSet stringValue="serviceName"/>
</L7p:SetVariable>
<L7p:Include>
<L7p:Enabl
<L7p:Base64Expression stringValue="Q1RUUklCVVQ="/>
<L7p:VariableToSet stringValue="SpCodeTablesSP.inputdata.TableCodeId"/>
</L7p:SetVariable>
<L7p:SetVariable>
<L7p:Base64Expression stringValue="U3BDb2RlVGFibGVzU1A="/>
<L7p:VariableToSet stringValue="serviceName"/>
</L7p:SetVariable>
<L7p:Include>
<L7p:Pol';
my $regex = qr/SetVariable>[\w\n\t\s=\":<>\/\-_.]*?stringValue=\"([\w\n\t\s=\":<>\/\-_.]*?)\"\/>[\w\n\t\s=\":<>\/\-_.]*?(?!booleanValue)[\w\n\t\s=\":<>\/\-_.]*?VariableToSet stringValue=\"serviceName\"[\w\n\t\s=\":<>\/\-_.]*?L7p:SetVariable>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}