re = /^(?=.+)(?:[1-9]\d*|0)?(?:\.\d+)?$/m
str = '123456
123.
.
.123
123.154574
.545.4584
+1454
+487.54587
-54587.7487
.1225-
.456+
454.4+
454.455874
45.45745687687.5678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end