import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.+)(?:[1-9]\\d*|0)?(?:\\.\\d+)?$";
final String string = "123456\n"
+ "123.\n"
+ ".\n"
+ ".123\n"
+ "123.154574\n"
+ ".545.4584\n"
+ "+1454\n"
+ "+487.54587\n"
+ "-54587.7487\n"
+ ".1225-\n"
+ ".456+\n"
+ "454.4+\n"
+ "454.455874\n"
+ "45.45745687687.5678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}