const regex = /^(?=.+)(?:[1-9]\d*|0)?(?:\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.+)(?:[1-9]\\d*|0)?(?:\\.\\d+)?$', 'gm')
const str = `123456
123.
.
.123
123.154574
.545.4584
+1454
+487.54587
-54587.7487
.1225-
.456+
454.4+
454.455874
45.45745687687.5678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}