#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.+)(?:[1-9]\d*|0)?(?:\.\d+)?$"
Local $sString = "123456" & @CRLF & _
"123." & @CRLF & _
"." & @CRLF & _
".123" & @CRLF & _
"123.154574" & @CRLF & _
".545.4584" & @CRLF & _
"+1454" & @CRLF & _
"+487.54587" & @CRLF & _
"-54587.7487" & @CRLF & _
".1225-" & @CRLF & _
".456+" & @CRLF & _
"454.4+" & @CRLF & _
"454.455874" & @CRLF & _
"45.45745687687.5678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")