use strict;
my $str = '123456
123.
.
.123
123.154574
.545.4584
+1454
+487.54587
-54587.7487
.1225-
.456+
454.4+
454.455874
45.45745687687.5678';
my $regex = qr/^(?=.+)(?:[1-9]\d*|0)?(?:\.\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}