// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^").unwrap();
let string = "List Paragraph 231) Identifier-RQ01901281/001
List Paragraph 232) Status-
List Paragraph 233) Alloc
List Paragraph 234) Statement-This is the statement
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}