re = /^/m
str = 'List Paragraph 231) Identifier-RQ01901281/001
List Paragraph 232) Status-
List Paragraph 233) Alloc
List Paragraph 234) Statement-This is the statement
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end