package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^`)
var str = `List Paragraph 231) Identifier-RQ01901281/001
List Paragraph 232) Status-
List Paragraph 233) Alloc
List Paragraph 234) Statement-This is the statement
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}