using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^";
string input = @"List Paragraph 231) Identifier-RQ01901281/001
List Paragraph 232) Status-
List Paragraph 233) Alloc
List Paragraph 234) Statement-This is the statement
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}