$re = '/^/m';
$str = 'List Paragraph 231) Identifier-RQ01901281/001
List Paragraph 232) Status-
List Paragraph 233) Alloc
List Paragraph 234) Statement-This is the statement
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);