// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/(?<address>[A-Za-z0-9\.\/]{1,})\/(?<sectorBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<leitoBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<language>por|en)$
").unwrap();
let string = "https://totvsfood.ninegrid.com.br/retail/pdv/UWXAZM/NTg2MQ==/MTAx/por
https://totvsfood.ninegrid.com.br/retail/app/UWXAZ/NDc5Nw==/FSDFSD==/en
https://staging.ninegrid.com.br/retail/app/LERL/MzAzMw==/MTAx/por
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}