using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/(?<address>[A-Za-z0-9\.\/]{1,})\/(?<sectorBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<leitoBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<language>por|en)$
";
string input = @"https://totvsfood.ninegrid.com.br/retail/pdv/UWXAZM/NTg2MQ==/MTAx/por
https://totvsfood.ninegrid.com.br/retail/app/UWXAZ/NDc5Nw==/FSDFSD==/en
https://staging.ninegrid.com.br/retail/app/LERL/MzAzMw==/MTAx/por
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}