# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^https:\/\/(?<address>[A-Za-z0-9\.\/]{1,})\/(?<sectorBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<leitoBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<language>por|en)$\n")
test_str = ("https://totvsfood.ninegrid.com.br/retail/pdv/UWXAZM/NTg2MQ==/MTAx/por\n"
"https://totvsfood.ninegrid.com.br/retail/app/UWXAZ/NDc5Nw==/FSDFSD==/en\n\n"
"https://staging.ninegrid.com.br/retail/app/LERL/MzAzMw==/MTAx/por\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.