re = /^https:\/\/(?<address>[A-Za-z0-9\.\/]{1,})\/(?<sectorBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<leitoBase64>(?:[A-Za-z0-9+\/]{4})*(?:[A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}={2}))\/(?<language>por|en)$
/m
str = 'https://totvsfood.ninegrid.com.br/retail/pdv/UWXAZM/NTg2MQ==/MTAx/por
https://totvsfood.ninegrid.com.br/retail/app/UWXAZ/NDc5Nw==/FSDFSD==/en
https://staging.ninegrid.com.br/retail/app/LERL/MzAzMw==/MTAx/por
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end