import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/(?<address>[A-Za-z0-9\\.\\/]{1,})\\/(?<sectorBase64>(?:[A-Za-z0-9+\\/]{4})*(?:[A-Za-z0-9+\\/]{4}|[A-Za-z0-9+\\/]{3}=|[A-Za-z0-9+\\/]{2}={2}))\\/(?<leitoBase64>(?:[A-Za-z0-9+\\/]{4})*(?:[A-Za-z0-9+\\/]{4}|[A-Za-z0-9+\\/]{3}=|[A-Za-z0-9+\\/]{2}={2}))\\/(?<language>por|en)$\n";
final String string = "https://totvsfood.ninegrid.com.br/retail/pdv/UWXAZM/NTg2MQ==/MTAx/por\n"
+ "https://totvsfood.ninegrid.com.br/retail/app/UWXAZ/NDc5Nw==/FSDFSD==/en\n\n"
+ "https://staging.ninegrid.com.br/retail/app/LERL/MzAzMw==/MTAx/por\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}