re = /^\s+"(?<id>[0-9]+)"\s+"(?<path>.+)"$/m
str = '"LibraryFolders"
{
"TimeNextStatsReport" "1613549278"
"ContentStatsID" "8305207799611222323"
"1" "E:\\\\Games\\\\SteamLibrary"
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end