using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s+""(?<id>[0-9]+)""\s+""(?<path>.+)""$";
string input = @"""LibraryFolders""
{
""TimeNextStatsReport"" ""1613549278""
""ContentStatsID"" ""8305207799611222323""
""1"" ""E:\\Games\\SteamLibrary""
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}