use strict;
my $str = '"LibraryFolders"
{
"TimeNextStatsReport" "1613549278"
"ContentStatsID" "8305207799611222323"
"1" "E:\\\\Games\\\\SteamLibrary"
}
';
my $regex = qr/^\s+"(?<id>[0-9]+)"\s+"(?<path>.+)"$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}