#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s+"(?<id>[0-9]+)"\s+"(?<path>.+)"$"
Local $sString = ""LibraryFolders"" & @CRLF & _
"{" & @CRLF & _
" "TimeNextStatsReport" "1613549278"" & @CRLF & _
" "ContentStatsID" "8305207799611222323"" & @CRLF & _
" "1" "E:\\Games\\SteamLibrary"" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")