$re = '/^\s+"(?<id>[0-9]+)"\s+"(?<path>.+)"$/m';
$str = '"LibraryFolders"
{
"TimeNextStatsReport" "1613549278"
"ContentStatsID" "8305207799611222323"
"1" "E:\\\\Games\\\\SteamLibrary"
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);