const regex = /[^a-zA-Z0-9]\B/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9]\\B', 'g')
const str = `Here is a test of some bullets
• Uno
• Two
• Tres
• Quarto
• Cinquo
Asdasasdas `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);