# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b(?<![[:punct:]])abc'n(?![[:punct:]])\b)"
test_str = ("123abc\n"
"assass\n"
"abc\n"
"abc-abc.\n"
"abc-123.\n"
"123-abc.\n"
"abc123\n"
" abc.\n"
"abc'n com 123\n"
"abc 123 abc.123 \n"
"www.abc.\n"
"abc.com\n"
"www.abc\n"
"www.abc.com\n"
"abc-foo\n"
"what.com abc is the place to abc. <-- That last abc should be highlighted.\n"
"what.com abc is the place to abc. That last abc should be highlighted.\n"
"www.abc. Foo bar\n"
"look\n"
"looking\n"
"tearsofsteel\n"
"www.tearsofsteel\n"
"www.tearsofsteel.org\n"
"www.Nleader.org\n"
"www3\n"
"www3we\n"
"www\n"
"www.\n"
"you're\n"
"Juggling.com\n"
"jugg")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.