import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?<![[:punct:]])abc'n(?![[:punct:]])\\b)";
final String string = "123abc\n"
+ "assass\n"
+ "abc\n"
+ "abc-abc.\n"
+ "abc-123.\n"
+ "123-abc.\n"
+ "abc123\n"
+ " abc.\n"
+ "abc'n com 123\n"
+ "abc 123 abc.123 \n"
+ "www.abc.\n"
+ "abc.com\n"
+ "www.abc\n"
+ "www.abc.com\n"
+ "abc-foo\n"
+ "what.com abc is the place to abc. <-- That last abc should be highlighted.\n"
+ "what.com abc is the place to abc. That last abc should be highlighted.\n"
+ "www.abc. Foo bar\n"
+ "look\n"
+ "looking\n"
+ "tearsofsteel\n"
+ "www.tearsofsteel\n"
+ "www.tearsofsteel.org\n"
+ "www.Nleader.org\n"
+ "www3\n"
+ "www3we\n"
+ "www\n"
+ "www.\n"
+ "you're\n"
+ "Juggling.com\n"
+ "jugg";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}