using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b(?<![[:punct:]])abc'n(?![[:punct:]])\b)";
string input = @"123abc
assass
abc
abc-abc.
abc-123.
123-abc.
abc123
abc.
abc'n com 123
abc 123 abc.123
www.abc.
abc.com
www.abc
www.abc.com
abc-foo
what.com abc is the place to abc. <-- That last abc should be highlighted.
what.com abc is the place to abc. That last abc should be highlighted.
www.abc. Foo bar
look
looking
tearsofsteel
www.tearsofsteel
www.tearsofsteel.org
www.Nleader.org
www3
www3we
www
www.
you're
Juggling.com
jugg";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}