$re = '/(\b(?<![[:punct:]])abc'n(?![[:punct:]])\b)/im';
$str = '123abc
assass
abc
abc-abc.
abc-123.
123-abc.
abc123
abc.
abc'n com 123
abc 123 abc.123
www.abc.
abc.com
www.abc
www.abc.com
abc-foo
what.com abc is the place to abc. <-- That last abc should be highlighted.
what.com abc is the place to abc. That last abc should be highlighted.
www.abc. Foo bar
look
looking
tearsofsteel
www.tearsofsteel
www.tearsofsteel.org
www.Nleader.org
www3
www3we
www
www.
you\'re
Juggling.com
jugg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);