const regex = /(\b(?<![[:punct:]])abc'n(?![[:punct:]])\b)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?<![[:punct:]])abc'n(?![[:punct:]])\\b)', 'gim')
const str = `123abc
assass
abc
abc-abc.
abc-123.
123-abc.
abc123
abc.
abc'n com 123
abc 123 abc.123
www.abc.
abc.com
www.abc
www.abc.com
abc-foo
what.com abc is the place to abc. <-- That last abc should be highlighted.
what.com abc is the place to abc. That last abc should be highlighted.
www.abc. Foo bar
look
looking
tearsofsteel
www.tearsofsteel
www.tearsofsteel.org
www.Nleader.org
www3
www3we
www
www.
you're
Juggling.com
jugg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}