re = /^(\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\.)+[a-zA-Z]{2,}$/m
str = 'Exemple@mail.com
exemple@mail.fr
exEmPle.exemple@mail.to
exemple.exemple.exemple@mail.org
EXEMPLE.exemple.EXEmple@mail.de
exemple+test@Màil.com
_exemple@Mail.com
_exemple.test@Mail-test.com
_exemple+test@mail-test-café.co.uk
exe_mple.test+tag@mail.com
exe_mple.test@mail.subdomain.com
exe_mple+test@mail.com
exemple@good2go.com
NotValid@mail.c
NotValid@mail
Not@.valid
@not.valid
@notvalid
notvalid@
notvalid.com
notvalid@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end