use strict;
my $str = 'Exemple@mail.com
exemple@mail.fr
exEmPle.exemple@mail.to
exemple.exemple.exemple@mail.org
EXEMPLE.exemple.EXEmple@mail.de
exemple+test@Màil.com
_exemple@Mail.com
_exemple.test@Mail-test.com
_exemple+test@mail-test-café.co.uk
exe_mple.test+tag@mail.com
exe_mple.test@mail.subdomain.com
exe_mple+test@mail.com
exemple@good2go.com
NotValid@mail.c
NotValid@mail
Not@.valid
@not.valid
@notvalid
notvalid@
notvalid.com
notvalid@';
my $regex = qr/^(\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\.)+[a-zA-Z]{2,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}