#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\.)+[a-zA-Z]{2,}$"
Local $sString = "Exemple@mail.com" & @CRLF & _
"exemple@mail.fr" & @CRLF & _
"exEmPle.exemple@mail.to" & @CRLF & _
"exemple.exemple.exemple@mail.org" & @CRLF & _
"EXEMPLE.exemple.EXEmple@mail.de" & @CRLF & _
"exemple+test@Màil.com" & @CRLF & _
"_exemple@Mail.com" & @CRLF & _
"_exemple.test@Mail-test.com" & @CRLF & _
"_exemple+test@mail-test-café.co.uk" & @CRLF & _
"exe_mple.test+tag@mail.com" & @CRLF & _
"exe_mple.test@mail.subdomain.com" & @CRLF & _
"exe_mple+test@mail.com" & @CRLF & _
"exemple@good2go.com" & @CRLF & _
"" & @CRLF & _
"NotValid@mail.c" & @CRLF & _
"NotValid@mail" & @CRLF & _
"Not@.valid" & @CRLF & _
"@not.valid" & @CRLF & _
"@notvalid" & @CRLF & _
"notvalid@" & @CRLF & _
"notvalid.com" & @CRLF & _
"notvalid@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")