import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\\.)+[a-zA-Z]{2,}$";
final String string = "Exemple@mail.com\n"
+ "exemple@mail.fr\n"
+ "exEmPle.exemple@mail.to\n"
+ "exemple.exemple.exemple@mail.org\n"
+ "EXEMPLE.exemple.EXEmple@mail.de\n"
+ "exemple+test@Màil.com\n"
+ "_exemple@Mail.com\n"
+ "_exemple.test@Mail-test.com\n"
+ "_exemple+test@mail-test-café.co.uk\n"
+ "exe_mple.test+tag@mail.com\n"
+ "exe_mple.test@mail.subdomain.com\n"
+ "exe_mple+test@mail.com\n"
+ "exemple@good2go.com\n\n"
+ "NotValid@mail.c\n"
+ "NotValid@mail\n"
+ "Not@.valid\n"
+ "@not.valid\n"
+ "@notvalid\n"
+ "notvalid@\n"
+ "notvalid.com\n"
+ "notvalid@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}