# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w+[._%+-]*)+@(([a-zA-Z0-9À-ÿ-]+-?)+\.)+[a-zA-Z]{2,}$"
test_str = ("Exemple@mail.com\n"
"exemple@mail.fr\n"
"exEmPle.exemple@mail.to\n"
"exemple.exemple.exemple@mail.org\n"
"EXEMPLE.exemple.EXEmple@mail.de\n"
"exemple+test@Màil.com\n"
"_exemple@Mail.com\n"
"_exemple.test@Mail-test.com\n"
"_exemple+test@mail-test-café.co.uk\n"
"exe_mple.test+tag@mail.com\n"
"exe_mple.test@mail.subdomain.com\n"
"exe_mple+test@mail.com\n"
"exemple@good2go.com\n\n"
"NotValid@mail.c\n"
"NotValid@mail\n"
"Not@.valid\n"
"@not.valid\n"
"@notvalid\n"
"notvalid@\n"
"notvalid.com\n"
"notvalid@")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.