re = /\b(?!\d(\d)\1)[01]+\b/im
str = '0101010, 1010101010
1
1111000'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result