#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\b(?!\d(\d)\1)[01]+\b"
Local $sString = "0101010, 1010101010" & @CRLF & _
"1" & @CRLF & _
"1111000"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)